Browsers & Plug-ins

Browser Recommendations

To take full advantage of all the features in Blackboard, you will need a supported Web browser and appropriate plug-ins.

Supported Browsers, Plugins & Operating Systems for Blackboard 9.1

IMPORTANT NOTE TO AOL USERS: America Online (AOL) users may not be able access Blackboard properly using the browser supplied with AOL. If you are using AOL you will need to download one of the supported browsers.

Internet Explorer Security Advisory
Microsoft issued a Security Advisory warning of attacks exploiting previously unknown security vulnerability in all versions of Internet Explorer (IE).  (Microsoft Security Advisory)  

Other recommendations:

  • Download and install the compatible version of Java recommended by Blackboard.
  • Disable any "pop-up blocker" software that you have installed on your computer.
  • Keep your virus software updated in order to scan for the latest viruses.
  • If you access from work or have a DSL connection and are running firewall software, you may experience difficulties. You will need to discuss this with your network security employees. They may or may not be able to allow access to the course, depending on their policies. DSL users will need to disable their firewall while using the chat tool (refer to the documentation in your firewall software for temporarily disabling the firewall).
  • If you use a public computer lab or library, you need to exit the browser completely when you are finished. (That is, all windows must be closed and the programs closed or exited.) This clears your username/password. If you do not exit the browser completely, the next user will have access to your course account.
  • Clear Your Browser's Cache. You may want to clear out the files stored in your cache to free up some space on your computer.

Plug-ins and Players

Browsers also use plug-ins and other helper applications to help them display Web documents. If you encounter an element (such as video or animation) that requires one of these helpers, you may see a message that your browser isn't equipped for that content type.

Clicking on the plug-in name below will take you to the Web site where you can download the desired plug-in.

Microsoft Download Center

Adobe Acrobat Reader

Flash Player

QuickTime

Java